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SQL DM FOR THE HYBRID CLOUD
As organizations migrate their databases to the cloud, database administrators need to consistently manage 

databases on-premise and in the cloud with existing staff and tools. While it is relatively straightforward to 

provision and manage databases on virtual machines in the cloud, cloud databases (that is, database as a 

service) require careful planning. Cloud databases are deceptively simple since cloud providers remove much 

of the complexity of configuring and managing on-premise databases. However, from the perspective of 

database administrators, is that a good thing or a bad thing?

Typical concerns with migration to the cloud are moving data to the cloud without impacting application 

performance, determining the best database-specific settings, ensuring that databases are being correctly 

maintained without access to the full database infrastructure, configuring for high availability and disaster 

recovery, balancing performance and cost, and managing databases in the cloud and on-premise without 

learning multiple tools.

There is no need to fear the cloud when managing the performance and availability of cloud and traditional 

databases with a single tool. By eliminating the steep learning curve associated with new tools for cloud 

databases, free up time for new organizational needs, adopt databases in the cloud confidently, and avoid 

making critical errors with new cloud databases.

With IDERA SQL Diagnostic Manager, monitor the performance of Microsoft SQL Server for physical, virtual,  

and cloud environments. SQL Diagnostic Manager runs on cloud virtual machines with Microsoft Windows.  

It can access mapped cloud drives. It supports monitoring of SQL Server instances on cloud virtual machines, 

and the SQL Server cloud databases Amazon Relational Database Service (RDS) for SQL Server and Microsoft 

Azure SQL Database.

Monitor the availability, health, and performance of SQL Server with SQL Diagnostic Manager.



Access cloud drives as network  
drives or removable drives.

INSTALL ON CLOUD VIRTUAL MACHINES

SQL Diagnostic Manager supports running on cloud virtual machines with Windows –  

such as Amazon Elastic Compute Cloud (EC2) and Azure Virtual Machines. Refer also to the product 

documentation “Supported installation scenarios” and “SQL Diagnostic Manager requirements”. 

 

ACCESS MAPPED CLOUD DRIVES

SQL Diagnostic Manager can access cloud storage that third-party software map as network drives or 

removable drives on Windows. Examples of such third-party software include CloudBerry Drive and Mountain 

Duck for Amazon Simple Storage Service (S3) and Azure Blob Storage.

Install SQL Diagnostic Manager to meet the  
unique needs of any SQL Server environment.

http://wiki.idera.com/display/SQLDoctor/Product+requirements?utm_medium=inasset&utm_content=pdf&utm_source=solutionbrief&utm_campaign=sql-diagnostic-manager-for-hybrid-cloud
http://wiki.idera.com/display/SQLDM/SQL+Diagnostic+Manager+requirements?utm_medium=inasset&utm_content=pdf&utm_source=solutionbrief&utm_campaign=sql-diagnostic-manager-for-hybrid-cloud
https://www.cloudberrylab.com/drive.aspx
https://mountainduck.io/
https://mountainduck.io/


MONITOR SQL SERVER ON CLOUD VIRTUAL MACHINES

SQL Diagnostic Manager supports monitoring  

instances of SQL Server running on cloud  

virtual machines with virtualization software  

that is compatible with VMWare and Microsoft  

Hyper-V – such as Amazon EC2 and Azure  

Virtual Machines.

Associate the monitored virtual instances  

of SQL Server with the virtualization host  

server that manages the virtual machines and  

the virtual machine on which the monitored  

instance of SQL Server is running with the  

“VM Configuration” window.

 

 

Add Host Server

To add a new host server: 

1.	 In the desktop console, from the main top menu, select “Tools → VM Configuration” Or 

In the “Manage Servers” window, select the “VM Configuration” button Or  

In Server Properties window, from the “Virtualization” tab, select the “VM Configuration” button.

2.	 In the “VM Configuration” window,  

select the “New” button.

3.	 In the “Virtualization Host Configuration” window: 

A. Enter the access information for the server. 

B. Select the “Test” button to verify connectivity. 

C. After a successful test, select the “OK” button. 

 
 

Refer also to the product documentation  

“Configure your virtual machine connections”.

In the “Virtualization Host Configuration” window, 
enter “Server”, “Name”, “User”, and “Password”.

Typical setup with SQL Diagnostic Manager 
monitoring a virtualized environment with VMware.

http://wiki.idera.com/display/SQLDM/Configure+your+virtual+machine+connections?utm_medium=inasset&utm_content=pdf&utm_source=solutionbrief&utm_campaign=sql-diagnostic-manager-for-hybrid-cloud


Setup Hyper-V

In virtualized environments with Hyper-V, the process of how SQL Diagnostic Manager collects and presents 

metrics is slightly different from that of a VMware setup. To successfully collect metrics for the host server and 

the virtual machine for Hyper-V, provide the Windows Management Instrumentation (WMI) credentials for the 

host server and the virtual machine, respectively.

To provide the WMI credentials for the Hyper-V host server:

 

1.	 In the desktop console, from the main top menu, select “Tools → VM Configuration → New” or  

“Tools → VM Configuration → View / Edit”.

2.	 In the “Virtualization Host Configuration” window, enter the WMI credentials. 

 

To provide the WMI credentials for the Hyper-V virtual machine:

 

1.	 In the desktop console, right-click on the name of the monitored instance and select “Properties”.

2.	 In the “Monitored SQL Server Properties” window, in the “OS Metrics” tab, enter the WMI credentials  

for the virtual machine.

 
Refer also to the product documentation “How SQL Diagnostic Manager works with a virtual environment” and 

specifically “Hyper-V user requirements”.

Typical setup with SQL Diagnostic  
Manager monitoring a virtualized  
environment with Hyper-V.

http://wiki.idera.com/display/SQLDM/How+SQL+Diagnostic+Manager+works+with+a+virtual+environment?utm_medium=inasset&utm_content=pdf&utm_source=solutionbrief&utm_campaign=sql-diagnostic-manager-for-hybrid-cloud
http://wiki.idera.com/x/CQDoAg?utm_medium=inasset&utm_content=pdf&utm_source=solutionbrief&utm_campaign=sql-diagnostic-manager-for-hybrid-cloud


Associate Monitored SQL Server Instance to Virtual Machine

After adding SQL Server instances to SQL Diagnostic Manager for monitoring, associate them  

with their host server and virtual machine:

 

1.	 In the desktop console, verify that the instance to associate to the host appears in the list.

2.	 Select the “Virtualization” column for the appropriate virtual instance, and then select the associated 

host server from the drop-down list.

3.	 Select the “Virtual Machine” column, and then select the name of the virtual machine where this 

instance resides. SQL Diagnostic Manager populates this drop-down list based on the servers on  

the selected host server.

4.	 Select the “Link Instances to VMs” button.

5.	 Select the “OK” button to save the changes and close this window. 

 

Refer also to the product documentation “Configure your virtual machine connections”.

Configure how SQL Diagnostic  
Manager monitors instances of  
SQL Server in the “Monitored SQL  
Server Properties” window.

http://wiki.idera.com/display/SQLDM/Configure+your+virtual+machine+connections?utm_medium=inasset&utm_content=pdf&utm_source=solutionbrief&utm_campaign=sql-diagnostic-manager-for-hybrid-cloud


MONITOR SQL SERVER CLOUD DATABASES

SQL Diagnostic Manager supports monitoring of the SQL Server cloud databases Azure SQL Database  

and Amazon RDS for SQL Server.

Select Cloud Provider While Adding Server

Add the SQL Server instances to monitor, configure all of the common options for SQL Server collection  

settings and alerts, and apply alert templates with the “Add Servers” wizard.

To add a new cloud server: 
 

1.	 In the desktop console, from the main top menu, select “File → Manage Servers”.

2.	 In the “Manage Servers” window, select the “Add” button.

3.	 Navigate the “Configure Authentication” window and the “Select Servers to Monitor”  

window of the “Add Servers” wizard.

4.	 In the “Add Servers” wizard, in the “Select cloud providers for the added servers” window,  

select a cloud provider for the monitored SQL Server instances hosted in the cloud.

5.	 Navigate the “Configure SQL Diagnostic Manager Collection” window, the “Configure OS Metric Collection” 

window, and the “Select Alert Template and Tags” window of the “Ad Servers” wizard. 

 

Refer also to the product documentation “Add your SQL Server instances” and specifically “Select cloud providers”.

Collected Metrics

View a wide range of information collected when monitoring the SQL Server cloud databases  

Amazon RDS for SQL Server (ARSS) and Microsoft Azure SQL Database (MASD) 

However, some information is not available yet. 

Sessions → Summary

AREA

Response Time

Sessions

Blocked Sessions

Lock Statistics → Average Wait Time

Lock Statistics → Deadlocks

METRIC ARSS MASD

http://wiki.idera.com/display/SQLDM/Add+your+SQL+Server+instances?utm_medium=inasset&utm_content=pdf&utm_source=solutionbrief&utm_campaign=sql-diagnostic-manager-for-hybrid-cloud
http://wiki.idera.com/display/SQLDM/Select+cloud+providers?utm_medium=inasset&utm_content=pdf&utm_source=solutionbrief&utm_campaign=sql-diagnostic-manager-for-hybrid-cloud


Collected Metrics Continued

Sessions → Summary

Sessions → Details

AREA

Lock Statistics → Requests

Lock Statistics → Timeouts

Lock Statistics → Waits

Lock Statistics → Wait Time

Blocked by

Connection

User Session

Status

Host

Net Library

Network Address

User

Execution Context

Application

Database

Transaction Isolation Level

Usage

Login Time

Last Activity

Physical I/O

CPU (ms)

METRIC ARSS MASD



Collected Metrics Continued

Sessions → Details

Overview → Details

AREA

Memory (kb)

Lock Information

Open Transactions

Wait Time (ms)

Resource

Blocking

Blocking Count

Tempdb Usage

Version Store Elapsed Seconds

Space Used in kb (Alloc / Dealloc) 

Session User Space

Task User Space

Session Internal Space

Task Internal Space

Available Memory

Batches

Batches Per Second

Blocked Sessions

Buffer Cache Hit Ratio

Buffer Cache Size

Checkpoint Writes

METRIC ARSS MASD



Collected Metrics Continued

Overview → Details

AREA

Checkpoint Writes Per Second

Client Computers

Connections

Connections Per Second

Data File Count

Data File Space Allocated

Data File Space used

Database Count

Disk Queue Length

Disk Time (Percent)

Full Scans

Full Scans Per Second

Lazy Writer Writes

Lazy Writer Writes Per Second

Lead Blockers

Lock Waits

Lock Waits Per Second

Log File Count

Log File Space Allocated

Log File Space Used

Log Flushes

METRIC ARSS MASD



Collected Metrics Continued

Overview → Details

AREA

Log Flushes Per Second

Maintenance Mode

OLE Automation Status

Open Transactions

OS CPU Privileged Activity

OS CPU User Time

OS Metrics Availability

OS Total Processor Activity

Packet Errors

Packet Errors Per Second

Packets Received

Packets Received Per Second

Packets Sent

Packets Sent Per Second

Page Life Expectancy

Page Lookups Per Second

Page Lookups Per Second

Page Reads

Page Reads Per Second

Page Splits

Page Splits Per Second

METRIC ARSS MASD



Refer also to the product documentation “Metric availability for instances hosted on the cloud”.

Collected Metrics Continued

Overview → Details

AREA

Page Writes

Page Writes Per Second

Pages Per Second

Physical Memory

Procedure Cache Hit ratio

Procedure Cache Size

Processor Queue Length

Read Ahead Pages

Read Ahead Pages Per Second

Read Write Errors

Response Time

Running Since

Server Version

SQL Compilations

SQL Compilations Per Second

SQL CPU Activity

SQL Memory Allocated

SQL Memory Used

SQL Memory Used Percent

METRIC ARSS MASD

http://wiki.idera.com/display/SQLDM/Metric+availability+for+instances+hosted+on+the+cloud?utm_medium=inasset&utm_content=pdf&utm_source=solutionbrief&utm_campaign=sql-diagnostic-manager-for-hybrid-cloud


SUMMARY
With SQL Diagnostic Manager, monitor the performance of SQL Server for physical, virtual, and 

cloud environments. Monitor queries and query plans to find the causes of blocks and deadlocks, 

plan for future capacity, monitor high availability groups, monitor the tempdb system database, 

view expert recommendations to optimize performance, alert predictively while avoiding false 

alerts, view a summary of top issues and alerts, and much more. Install and deploy SQL Diagnostic 

Manager to meet the unique needs of any SQL Server environment.

Monitor, analyze, and plan for your SQL Server with SQL Diagnostic Manager.

Start for FREE

IDERA.com

https://www.idera.com/productssolutions/sqlserver/sqldiagnosticmanager/freetrialsubscriptionform?utm_medium=inasset&utm_content=pdf&utm_source=solutionbrief&utm_campaign=sql-diagnostic-manager-for-hybrid-cloud

